Swoole Compiler 授权安装向导

(Rizhuti-V2需要Swoole Compiler加密扩展,当前仅支持PHP7.4)
如果您环境是虚拟主机不支持自定义安装php扩展。
请去FTP或者文件管理删除 \wp-content\themes\rizhuti-v2\ 主题目录即可恢复网站。

环境信息

  • 操作系统 : Linux localhost.localdomain 2.6.32-754.15.3.el6.x86_64 #1 SMP Tue Jun 18 16:25:32 UTC 2019 x86_64
  • PHP版本 : 7.4.16
  • PHP运行环境 : cgi-fcgi
  • PHP配置文件 : /usr/local/zend/php7.4/etc/php.ini
  • PHP扩展安装目录 : /usr/local/zend/php7.4/include/php/ext
  • PHP是否线程安全 : 非线程安全
  • 是否安装swoole_loader : 未安装

安装和配置Swoole Loader 扩展

    1 - 点击下载 unix PHP7.4 Swoole Loader扩展文件

    2 - 安装Swoole Loader

    将刚才下载的Swoole Loader扩展文件(swoole_loader74.so)上传到当前PHP的扩展安装目录中:/usr/local/zend/php7.4/include/php/ext

    3 - 修改php.ini配置(如已修改配置,请忽略此步骤,不必重复添加)

    编辑此PHP配置文件:/usr/local/zend/php7.4/etc/php.ini
    在此文件底部结尾处加入如下配置并且保存 :extension=swoole_loader74.so
    注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致

    4 - 重启PHP或者重启服务器